Tuesday, May 06, 2008

Gentoo Wvdial, Segmentation Fault

Ive found this error (segmentation fault, hmm.. sound interesting :P) when using wvdial to connect to the internet (which never happen before i upgrading my machine)..
$ wvdial
--> WvDial: Internet dialer version 1.60
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
--> Sending: AT+CGDCONT=1,"IP","indosatgprs"
--> Modem initialized.
Segmentation fault.

After googling and hunting, ive found out that some people has a same problem with me, and also at the right place to check about gentoo bugs (206579) also the patch that ive already use 218504 and the one that i develop arent working :(.

Ive already patch the wvstream, using this patch (carefull in using the patch, u have to put it in ebuild, because if u dont do so then after u re-emerge, the patch wont work) and rebuild wvdial, wvstreams, ppp, glibc and gcc (some friends said this is a bug in gentoo's glibc package, but the toolchain guys still not responding about it). So, now im still using pon (pppconfig) to connect to internet using my Claymore.

Somebody could help? :)

images taken from http://avionhelico.chez-alice.fr

No comments:

Post a Comment